Skip to content

AxoTools tools

This page is under construction: please check back again later.

Go back to Documentation

Axo tool

AxoTools tool Axo Tool

The Axo tool provides several functions. You can create common reference points to guide in placing art when it’s projected to or from an axonometric view. It also allows you to move art along an orthographic or axonometric axis. You can move the locations of common reference points. The section on the Transformations panel describes how to use the Axo tool to assign an anchor point for a Transformation object.

AxoTools common reference point dialogClick to define a common reference point, which can be described as a point that represents the same place in each of your orthographic views, as well as the corresponding point in your axonometric view. When the dialog appears, you can choose which view the chosen point represents, or click Clear to remove all defined reference points. Reference points are saved with the document, and when this tool is selected they will appear marked with a crosshairs symbol.

AxoTools common reference pointsAs you project art with common reference points defined for both ortho and axo views, the axonometric art will appear aligned to each other relative to the reference points. We call this “project in place.” This is probably best explained with the introductory video.

To move a reference point, click and drag — shortly after you’ve started dragging, press and hold the Cmd/Ctl key. As you move an orthographic reference point, note how all of the points move accordingly.

If you drag the tool with art selected, it will be moved constrained to the current axes. Press the Option/Alt key to drag a copy of the art, rather than the original. If axo art is selected and you drag in an ortho view, the art will be “moved by reference” in the corresponding direction by the corresponding distance.

AxoTools common reference points in camera drawingIf you have selected art in the axonometric view, you can move it a given distance and direction using one of the orthographic views as a reference. Just drag (press Shift to constrain the movement to vertical or horizontal) in any ortho view.

Once you have defined a common reference point, you can quickly navigate to it again with menu items in View > Go to Axonometric View. 

These behaviors work together to help you quickly and accurately position your projected art in the axo view without tedious measuring and moving.

Axo Line tool

AxoTools Line toolThe Axo Line tool allows you to click and drag to draw a straight line constrained to whatever your axes are, as defined by your Projection panel. Hold down the shift key to constrain lines to 45 degrees, or the Option/Alt key to draw straight lines without constraints.

Several behaviors of the tool can be selected in the AxoTools Draw Settings panel found at Window > AxoTools > AxoTools Draw Settings.

AxoTools Line tool settingsCheck “Apply stroke widths to new art” to automatically apply one of two standard line widths for the drawing style you define in the Axo Draw Settings panel. If the “Apply stroke” option is unchecked, lines will be created in a default style of black with round caps and joins with 0.5 pt. width.

To use a different stroke style, Option/Alt-click on another path to inherit its settings — the cursor will change to an eyedropper to indicate that it has found a path to read. Note that only paths with a stroke applied will be read, and only the stroke properties will be used (the fill will be ignored). All new paths created with the Axo Line tool will then have these path style properties. If the last path drawn with the Axo Line tool is selected, that path will be assigned the imported properties.

To toggle line weights between detail and outline weight, click twice on a path.

If the Axo Draw Settings is set to automatically assign stroke widths, the current detail or outline width will be applied, otherwise the selected path will have the same width as the path clicked. Stroke weights entered in the Axo Draw Settings panel can be specified in points or millimeters by typing “pt” or “mm” after the amount. These stroke weights will continue to display in these units until the other is specified, regardless of the current ruler units.

When “Automatically concatenate lines” is selected in the Axo Draw Settings panel, paths that are modified with the Axo Line tool will retain the original path’s properties. New paths will be drawn with the Axo Line tool’s current settings, regardless of the properties of the current pen properties or selected art’s properties. With “Apply stroke widths” active, click a path with the Axo Line tool to toggle between the two weights. Click on a selected path to toggle its weight to the new pen settings. Note that only the stroke width will be changed, not its color, dash pattern, or other properties.

With the option to Automatically concatenate lines checked, you can draw a new path beginning at the endpoint of another path, and extend it as one continuous path. To quickly temporarily reverse the setting, press Cmd/Ctl after you start to drag the new path and continue to press until after releasing the mouse or stylus.

While dragging with the Axo Line tool, paths will be constrained to the angles of the current axes. Press Shift to constrain angles to increments of 45° or press Option/Alt to create lines unconstrained.

Axo Tangent Line tool

Tangent Line tool

To use the Axo Tangent Line tool, move your cursor over a path near the point you want the tangent line to begin. You’ll see a guide line appear showing the tangent angle. Click on the path and drag a line, which will be constrained tangent to the path. If you press Alt or Option, the tangent point will be adjusted, if possible, to align with your cursor.
tangent line tool dragging
 
If you Option/Alt drag to another path, the tool will draw concentric rings when it’s near a tangent point there. For best results, find the spot where the rings collapse into a solid blue ball.
 
Tangent points at both ends will be fine-tuned for more accuracy than the dragged line.
 
If your Draw Settings have checked “Automatically concatenate lines” then paths at both the start and end points will be cut and concatenated (joined). While dragging, you can press the keys “J” to toggle line concatenation or “W” to automatically assign your preset detail stroke width to path remnants. The stroke of your source path will remain the same, although its fill (except for patterns or gradients) will be set to None so that it doesn’t obscure other art objects while you revise your outline path.
 
The preferences includes a new item for “Curve tangent precision” which will affect both the Tangent Line tool and the extruding process for curve fitting. The default value of 0.1 will probably work fine for most, if not all, of your work, but you can adjust it as high as 1 for faster performance or as fine as 0.001 for the most precision.

Axo Arc tool

arc toolAs you drag with the Axo Arc tool, the arc will appear highlighted. You can drag the arc forward or backward, left or right. Guide lines will appear to show the location of the arc center as well as a tangent line of the arc’s exit angle. If your preferences select Help text, the tool will also display the current arc’s extent angle and radius.

arc tool usageAs you drag, press the Alt or Option key to adjust a fixed radius, or press the Ctl or Cmd key to change the arc’s starting angle. Press the shift key to constrain the arc’s extent or angle to increments of 45°.

Click with the tool to display a dialog box to create an arc numerically. The Start angle represents the angle before projecting the arc to its axonometric plane, so you won’t need to hassle with converting angles on the screen to simple flat art. For example, a Start angle of 0° in the dialog would be drawn at 30° in an isometric top or right side view, and a 90° extent makes a quarter of a circle, regardless of the angles on the screen. Here, too, you can specify the radius of the arc with dimensions given in units you specify, such as feet or meters, and scaled to the current document ratio defined in your AxoTools preferences. Finally, choose whether the arc should curve to the left or to the right.

arc dialog

This feature is FREE, no license required to use the Axo Arc tool.

Axo Ellipse tool

arc tool
As you drag with the Axo Ellipse tool, the ellipse will appear projected onto your current axonometric plane. If your preferences select Help text, the tool will also display the current width and height using the units specified in your preferences and scaled to your document scale.

ellipse tool usageAs you drag, press the Alt or Option key to anchor the ellipse at its center point. Press the shift key to constrain the ellipse to a circle.

Click with the tool to display a dialog box to create an ellipse numerically. Enter a height and width, which will be scaled according to the document scale in your preferences. You can also enter a depth to extrude the ellipse to create a cylinder. Stroke widths and shaded fills will be adjusted according to your Axo Draw settings if you have that options set in your preferences.

ellipse dialog

Axo Rectangle tool

rectangle toolThe Axo Rectangle tool works similar to the Axo Ellipse tool, except that it draws a rectangle. Like the Axo Ellipse tool, pressing the Shift or Alt/Option keys work as they do in Adobe Illustrator’s built-in Ellipse or Rectangle tools, only the art is drawn on an axonometric plane.

rectangle tool usageClick with the tool to display a dialog box to create a rectangle numerically. Enter a height and width, which will be scaled according to the document scale in your preferences. You can also enter a depth value to extrude the ellipse to create a box. It can be styled according to your Axo Draw settings and preferences settings.

rectangle dialog

Axo Scale tool

AxoTools Scale toolThe Axo Scale tool allows you to scale art within an axonometric plane. It works similar to Adobe Illustrator’s standard Scale tool, but within an axonometric plane.

AxoTools Scale tool usageIts default anchor point is the center of the selection, but you can click to define a new anchor point. Press Alt/Option to cycle through the three projection planes. The plugin will display colored lines indicating the two major axis for the current plane. A cube annotation will appear with one of the three faces highlighted, color-coded with the protractor in either red (right), blue (left) or green (top). Press the Shift key while dragging to constrain the scaling to the direction of the protractor lines.

Note: To keep the UI for Axo Scale tool simple and intuitive, it will not scale artwork constrained proportional to the original. To achieve this same result, scale the art with Adobe Illustrator’s standard Scale tool.
AxoTools Scale tool dialog
To scale numerically, Alt/Option click where you want your anchor point, then fill ini the horizontal and vertical scales, then select a face to scale on and click OK.

Axo Rotate tool

AxoTools Rotate tool iconThe Axo Rotate tool will allow you to rotate artwork within the plane of its axonometric projection. It functions similar to Adobe’s Rotate tool in that its default anchor point is the center of the selection, but you can click to place the anchor anywhere you’d like.AxoTools Rotate tool usage

The plugin will display an axonometric protractor with colored lines every 90° and gray lines every 15°. Press Alt/Option to cycle through the three projection planes. A cube annotation will appear with one of the three faces highlighted, color-coded with the protractor in either red (right), blue (left) or green (top).

AxoTools Rotate tool dialogPress the Shift key while dragging to constrain the rotation to increments of 15°.

To rotate art numerically on a projected plane, Alt/Option click on a location for the anchor point of the rotation. In the dialog box that appears, fill in the rotation amount and the face upon which to rotate.

Axo Shear tool

AxoTools Rotate tool iconThe Axo Shear tool will allow you to shear artwork within the plane of its axonometric projection. It functions similar to Adobe’s Shear tool in that its default anchor point is the center of the selection, but you can click to place the anchor anywhere you’d like.

AxoTools Rotate tool usage

The plugin will display a cube annotation with one of the three faces highlighted, color-coded with the protractor in either red (right), blue (left) or green (top). The chosen axonometric plane’s X and Y axis will be shown.

AxoTools Rotate tool dialogPress the Shift key while dragging to constrain the shear to increments of 15°.

To shear art numerically on a projected plane, Alt/Option click on a location for the anchor point of the operation. In the dialog box that appears, fill in the shear amount, the axis angle to shear on, and the face upon which to shear.

Axo Extrude tool

AxoTools Extrude tool iconThe Axo Extrude tool extrudes a path along an axonometric axis. To use it, select a path or compound path and drag along an axonometric axis. To extrude orthographic art into an axonometric shape before extruding it, press the Alt/Option key as you drag. Click without dragging to extrude other selected artwork along the same axis and same distance.AxoTools Draw Settings panel

When extruding, you have a number of options for how the art ic created, which are selected in the AxoTools Draw Settings panel found in the menu at Window > AxoTools > AxoTools Draw Settings.

There are four fill options. Wireframe simply extrudes the art with no fills. Fill with white creates panels for each face filled with white. A third option uses the art’s current stroke and fill colors. Shaded object color starts with the path’s fill color (or adds a light gray fill if the art is not filled already) as the color for the left face. The top face is tinted lighter and the right face is darkened to simulate an upper-left light source.

Hidden faces can be included in your extruded art or omitted for simplicity.

Strokes can be added to the art using predefined thick and thin widths using the “air-behind” method. When using this option, the filled panels will have no stroke. Stroke widths can be entered in any units supported by Illustrator’s many fields, such as “in” or “pt” or “mm.”

The option to automatically concatenate lines applies to the Axo Line tool described later.

AxoTools Extrude panelTo extrude path art numerically, open the AxoTools Extrude panel found at Window > AxoTools > AxoTools Extrude.

The angle is the direction the object should be extruded. Click on one of the six arrow symbols to set it to an angle along a current axis as set in the Projection panel or enter a value in the text field. As with Illustrator’s angles, 0 degrees points to the right and positive values wind counterclockwise (e.g., up is 90° and left is 180°).

Project ortho art to axonometric will allow you to project a rectangle to an axonometric cube or a circle to an axonometric cylinder, as long as the angle chosen is along one of the current axes.

The distance to extrude is shown in the current document’s ruler units, but you can enter a different measurement if you wish, and it will be converted to the default unit. For example, if your document uses points, you can enter “1 mm” and it will be converted to the equivalent of 2.835 points.

Click the Extrude button to extrude selected path art.

Double-click the labels for the Angle or Distance field to automatically enter the last value measured by the Axo Measure tool.

Extrude distance from orthographic views:

When you extrude in an axonometric view, you can specify the depth of the extrusion by dragging an equivalent distance in one of your orthographic views. For example:

AxoTools Extrude tool usage

The distance will be foreshortened for the angle of the axis and the direction will correspond with the direction you drag in the ortho view.

Axo Measure tool

info panel
The new Measure tool allows you to measure distances and angles in any of the three axonometric axes, scaled for the foreshortening factor of that plane as well as the direction of the measurement within that plane. Measurements are displayed for all axo planes as well as orthographic, and distances along the auxiliary depth axis.

In the Info panel, choose a set of measurements to display, choose “Auto” to let the tool guess what you’re measuring based on the direction you drag the mouse, or choose “All” to see all results.

measure toolTo use the tool, simply click and drag to measure a distance and an angle. To measure the difference between two angles on an axonometric plane, click once to set an anchor point, then drag an arc from one point to another.

Press Shift to constrain to the nearest 45°, or press Alt/Option if you’d like the tool constrained along your current axonometric axes.

You can automatically enter values from the orthographic measurements into the Extrude panel’s Distance or Angle fields, the Projection panel’s X or Z axis fields, or the Transformations panel Extrude distance field, just double-click the field’s label. To enter values into the Transformation’s Move/Rotate field, simply press “d” or “a” for “distance” or “angle” as applicable.